To run the e-timecard application, you must use a browser that supports JavaScript--Internet Explorer 6+ or Netscape 7.2+--and enable JavaScript in your browser. For more information, contact your Administrator.
Welcome to Quantell's E-Time System
 

Welcome to JAMIS Software Corporation

Frequently Asked Questions

   
 
   
 
Go to: 
 
Arrow Bullet Time Entry Instructions
Arrow Bullet Approver Instructions
 
JAMIS e-timecard verison 5.00.02 © Copyright 2005 JAMIS Software Corporation. All Rights Reserved.
For e-timecard to function properly, use Internet Explorer 6.0 or Netscape 7.1,
enable JavaScript, and disable pop-up blockers for the e-timecard website.